const regex = /^\[[^]]+\]: builds\/app\/(.+?)\.(ipa|apk)$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[[^]]+\\]: builds\\\/app\\\/(.+?)\\.(ipa|apk)$', 'm')
const str = `[14:54:35]: [32m-------------------------------------------------[0m
[14:54:35]: [32m--- Step: Switch to android upload_to_s3 lane ---[0m
[14:54:35]: [32m-------------------------------------------------[0m
[14:54:35]: Cruising over to lane 'android upload_to_s3' 🚖
[14:54:37]: builds/app/oneoff/android/22.26.2_15_225877//app-oneoff-release.apk
[14:54:37]: Cruising back to lane 'android build_oneoff' 🚘`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}