// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[[^]]+\]: builds\/app\/(.+?)\.(ipa|apk)$").unwrap();
let string = "[14:54:35]: [32m-------------------------------------------------[0m
[14:54:35]: [32m--- Step: Switch to android upload_to_s3 lane ---[0m
[14:54:35]: [32m-------------------------------------------------[0m
[14:54:35]: Cruising over to lane 'android upload_to_s3' 🚖
[14:54:37]: builds/app/oneoff/android/22.26.2_15_225877//app-oneoff-release.apk
[14:54:37]: Cruising back to lane 'android build_oneoff' 🚘";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}