#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[[^]]+\]: builds\/app\/(.+?)\.(ipa|apk)$"
Local $sString = "[14:54:35]: [32m-------------------------------------------------[0m" & @CRLF & _
"[14:54:35]: [32m--- Step: Switch to android upload_to_s3 lane ---[0m" & @CRLF & _
"[14:54:35]: [32m-------------------------------------------------[0m" & @CRLF & _
"[14:54:35]: Cruising over to lane 'android upload_to_s3' 🚖" & @CRLF & _
"[14:54:37]: builds/app/oneoff/android/22.26.2_15_225877//app-oneoff-release.apk" & @CRLF & _
"[14:54:37]: Cruising back to lane 'android build_oneoff' 🚘"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")