using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[[^]]+\]: builds\/app\/(.+?)\.(ipa|apk)$";
string input = @"[14:54:35]: [32m-------------------------------------------------[0m
[14:54:35]: [32m--- Step: Switch to android upload_to_s3 lane ---[0m
[14:54:35]: [32m-------------------------------------------------[0m
[14:54:35]: Cruising over to lane 'android upload_to_s3' 🚖
[14:54:37]: builds/app/oneoff/android/22.26.2_15_225877//app-oneoff-release.apk
[14:54:37]: Cruising back to lane 'android build_oneoff' 🚘";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}