use strict;
my $str = 'J\'attrape les ours et les oursons';
my $regex = qr`ours(on|e)?s?`mp;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";