using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ours(on|e)?s?";
string substitution = @"";
string input = @"J'attrape les ours et les oursons";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}