// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w{1}\:{1}\/{2})(\w+\/{1})+(\w+\.{1}\w+){1}").unwrap();
let string = "c://ProgramFiles/MyDir1/MyDir2/file.ext";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}