#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w{1}\:{1}\/{2})(\w+\/{1})+(\w+\.{1}\w+){1}"
Local $sString = "c://ProgramFiles/MyDir1/MyDir2/file.ext"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")