re = /(\w{1}\:{1}\/{2})(\w+\/{1})+(\w+\.{1}\w+){1}/
str = 'c://ProgramFiles/MyDir1/MyDir2/file.ext'
# Print the match result
str.match(re) do |match|
puts match.to_s
end