package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w{1}\:{1}\/{2})(\w+\/{1})+(\w+\.{1}\w+){1}`)
var str = `c://ProgramFiles/MyDir1/MyDir2/file.ext`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}