$re = '`(\w{1}\:{1}\/{2})(\w+\/{1})+(\w+\.{1}\w+){1}`';
$str = 'c://ProgramFiles/MyDir1/MyDir2/file.ext';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);