import Foundation
let pattern = #"https?:\/\/([a-z0-9]+\.)+(at|de|ch)(\/[a-z]+)*\/?(\?[a-z]+=[a-z]*(&[a-z]+=[a-z]*)*)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://a1.at
http://orf.at/
https://tc.tugraz.at/main
http://www.derstandard.at/kultur/
https://wikipedia.at/wiki/regex/
http://duckduckgo.at/?q=regex
https://gdi.ist.tugraz.at?user=student
http://gdi.ist.tugraz.at/login?course=gdi&role=student
http://tugraz.at?emptyparam=
ε (Leerstring)
http
http://
http://www
http://.at
http://orf.at//
https://de.wikipedia.org
http://tugraz.at/?
http://gdi.ist.tugraz.at/?user=student&
http://?user=student
https://tugraz.at?user
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)