const regex = /https?:\/\/([a-z0-9]+\.)+(at|de|ch)(\/[a-z]+)*\/?(\?[a-z]+=[a-z]*(&[a-z]+=[a-z]*)*)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/([a-z0-9]+\\.)+(at|de|ch)(\\\/[a-z]+)*\\\/?(\\?[a-z]+=[a-z]*(&[a-z]+=[a-z]*)*)?', 'g')
const str = `http://a1.at
http://orf.at/
https://tc.tugraz.at/main
http://www.derstandard.at/kultur/
https://wikipedia.at/wiki/regex/
http://duckduckgo.at/?q=regex
https://gdi.ist.tugraz.at?user=student
http://gdi.ist.tugraz.at/login?course=gdi&role=student
http://tugraz.at?emptyparam=
ε (Leerstring)
http
http://
http://www
http://.at
http://orf.at//
https://de.wikipedia.org
http://tugraz.at/?
http://gdi.ist.tugraz.at/?user=student&
http://?user=student
https://tugraz.at?user`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}