package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/([a-z0-9]+\.)+(at|de|ch)(\/[a-z]+)*\/?(\?[a-z]+=[a-z]*(&[a-z]+=[a-z]*)*)?`)
var str = `http://a1.at
http://orf.at/
https://tc.tugraz.at/main
http://www.derstandard.at/kultur/
https://wikipedia.at/wiki/regex/
http://duckduckgo.at/?q=regex
https://gdi.ist.tugraz.at?user=student
http://gdi.ist.tugraz.at/login?course=gdi&role=student
http://tugraz.at?emptyparam=
ε (Leerstring)
http
http://
http://www
http://.at
http://orf.at//
https://de.wikipedia.org
http://tugraz.at/?
http://gdi.ist.tugraz.at/?user=student&
http://?user=student
https://tugraz.at?user`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}