# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https?:\/\/([a-z0-9]+\.)+(at|de|ch)(\/[a-z]+)*\/?(\?[a-z]+=[a-z]*(&[a-z]+=[a-z]*)*)?"
test_str = ("http://a1.at\n"
"http://orf.at/\n"
"https://tc.tugraz.at/main\n"
"http://www.derstandard.at/kultur/\n"
"https://wikipedia.at/wiki/regex/\n"
"http://duckduckgo.at/?q=regex\n"
"https://gdi.ist.tugraz.at?user=student\n"
"http://gdi.ist.tugraz.at/login?course=gdi&role=student\n"
"http://tugraz.at?emptyparam=\n\n"
"ε (Leerstring)\n"
"http\n"
"http://\n"
"http://www\n"
"http://.at\n"
"http://orf.at//\n"
"https://de.wikipedia.org\n"
"http://tugraz.at/?\n"
"http://gdi.ist.tugraz.at/?user=student&\n"
"http://?user=student\n"
"https://tugraz.at?user")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.