using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/([a-z0-9]+\.)+(at|de|ch)(\/[a-z]+)*\/?(\?[a-z]+=[a-z]*(&[a-z]+=[a-z]*)*)?";
string input = @"http://a1.at
http://orf.at/
https://tc.tugraz.at/main
http://www.derstandard.at/kultur/
https://wikipedia.at/wiki/regex/
http://duckduckgo.at/?q=regex
https://gdi.ist.tugraz.at?user=student
http://gdi.ist.tugraz.at/login?course=gdi&role=student
http://tugraz.at?emptyparam=
ε (Leerstring)
http
http://
http://www
http://.at
http://orf.at//
https://de.wikipedia.org
http://tugraz.at/?
http://gdi.ist.tugraz.at/?user=student&
http://?user=student
https://tugraz.at?user";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}