import Foundation
let pattern = #"(?!(([^"]*"){2})*[^"]*$)\n+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"Lorem Ipsum";"lorem lorem
ipsume
fezohf
pefz
";""
"dzafmkahvgaez";"oufhbezoà";" bfoezi";"dzadaz
dazdjha
daz
"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)