# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!(([^"]*"){2})*[^"]*$)\n+//g;t' <<< "\"Lorem Ipsum\";\"lorem lorem
ipsume
fezohf
pefz
\";\"\"
\"dzafmkahvgaez\";\"oufhbezoà\";\" bfoezi\";\"dzadaz
dazdjha
daz
\""