use strict;
my $str = '"Lorem Ipsum";"lorem lorem
ipsume
fezohf
pefz
";""
"dzafmkahvgaez";"oufhbezoà";" bfoezi";"dzadaz
dazdjha
daz
"';
my $regex = qr/(?!(([^"]*"){2})*[^"]*$)\n+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";