$re = '/(?!(([^"]*"){2})*[^"]*$)\n+/';
$str = '"Lorem Ipsum";"lorem lorem
ipsume
fezohf
pefz
";""
"dzafmkahvgaez";"oufhbezoà";" bfoezi";"dzadaz
dazdjha
daz
"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;