import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!(([^\"]*\"){2})*[^\"]*$)\\n+";
final String string = "\"Lorem Ipsum\";\"lorem lorem\n"
+ "ipsume\n"
+ "fezohf\n"
+ "pefz\n"
+ "\";\"\"\n"
+ "\"dzafmkahvgaez\";\"oufhbezoà\";\" bfoezi\";\"dzadaz\n"
+ "dazdjha\n"
+ "daz\n"
+ "\"";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}