// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(https?:\/\/)?apps\.apple\.com(\/[a-zA-Z]{2})?\/(app|developer)\/.+").unwrap();
let string = "https://apps.apple.com/us/app/poppy-playtime-chapter-1/id1610947489
http://apps.apple.com/SA/app/poppy-playtime-chapter-1/id1610947489
https://apps.apple.com/app/id1610947489
apps.apple.com/app/id1610947489
https://apps.apple.com/us/developer/mobgames/id1608636552
https://apps.apple.com/us/devEloper/mobgames/id1608636552";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}