package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(https?:\/\/)?apps\.apple\.com(\/[a-zA-Z]{2})?\/(app|developer)\/.+`)
var str = `https://apps.apple.com/us/app/poppy-playtime-chapter-1/id1610947489
http://apps.apple.com/SA/app/poppy-playtime-chapter-1/id1610947489
https://apps.apple.com/app/id1610947489
apps.apple.com/app/id1610947489
https://apps.apple.com/us/developer/mobgames/id1608636552
https://apps.apple.com/us/devEloper/mobgames/id1608636552`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}