# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(https?:\/\/)?apps\.apple\.com(\/[a-zA-Z]{2})?\/(app|developer)\/.+"
test_str = ("https://apps.apple.com/us/app/poppy-playtime-chapter-1/id1610947489\n"
"http://apps.apple.com/SA/app/poppy-playtime-chapter-1/id1610947489\n"
"https://apps.apple.com/app/id1610947489\n"
"apps.apple.com/app/id1610947489\n"
"https://apps.apple.com/us/developer/mobgames/id1608636552\n"
"https://apps.apple.com/us/devEloper/mobgames/id1608636552")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.