$re = '/(https?:\/\/)?apps\.apple\.com(\/[a-zA-Z]{2})?\/(app|developer)\/.+/mi';
$str = 'https://apps.apple.com/us/app/poppy-playtime-chapter-1/id1610947489
http://apps.apple.com/SA/app/poppy-playtime-chapter-1/id1610947489
https://apps.apple.com/app/id1610947489
apps.apple.com/app/id1610947489
https://apps.apple.com/us/developer/mobgames/id1608636552
https://apps.apple.com/us/devEloper/mobgames/id1608636552';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);