#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(https?:\/\/)?apps\.apple\.com(\/[a-zA-Z]{2})?\/(app|developer)\/.+"
Local $sString = "https://apps.apple.com/us/app/poppy-playtime-chapter-1/id1610947489" & @CRLF & _
"http://apps.apple.com/SA/app/poppy-playtime-chapter-1/id1610947489" & @CRLF & _
"https://apps.apple.com/app/id1610947489" & @CRLF & _
"apps.apple.com/app/id1610947489" & @CRLF & _
"https://apps.apple.com/us/developer/mobgames/id1608636552" & @CRLF & _
"https://apps.apple.com/us/devEloper/mobgames/id1608636552"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")