re = /^(0[1-9]|[1-9][ABab\d])\d{3}$/m
str = '00000
00123
01200
20456
99123
78646
2A000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end