package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0[1-9]|[1-9][ABab\d])\d{3}$`)
var str = `00000
00123
01200
20456
99123
78646
2A000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}