#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0[1-9]|[1-9][ABab\d])\d{3}$"
Local $sString = "00000" & @CRLF & _
"00123" & @CRLF & _
"01200" & @CRLF & _
"20456" & @CRLF & _
"99123" & @CRLF & _
"78646" & @CRLF & _
"2A000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")