const regex = /^(0[1-9]|[1-9][ABab\d])\d{3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0[1-9]|[1-9][ABab\\d])\\d{3}$', 'gm')
const str = `00000
00123
01200
20456
99123
78646
2A000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}