$re = '/^(0[1-9]|[1-9][ABab\d])\d{3}$/m';
$str = '00000
00123
01200
20456
99123
78646
2A000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);