import Foundation
let pattern = #"\A(?:(?:^(?<type>feat|fix|ci|chore|docs|test|style|refactor|build|perf|revert)(?:\((?<scope>.+)\))?(?<breaking>!)?:\s(?<subject>.{3,})$)(?:(?:(?<BLANK_LINE>\n^$\n)(?<body>(?:^.{3,}$\n?)+))?(?<BLANK_LINE2>\n^$\n)(?:(?<breaking_change>^BREAKING\sCHANGE:\s[\s\w]+$)\n)?(?:(?<footer>^\w+:\s.+)))?\n?|)\Z"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
feat(regular-expression_conventionalCommitsỦniçode)!: Subject-3302 úniçode samlpe/
Validating everything for best conventionalCommits usage
thanks
Éverything is Ủniçode now
www.example.com
BREAKING CHANGE: breaking change description
See: footer.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)