# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\A(?:(?:^(?<type>feat|fix|ci|chore|docs|test|style|refactor|build|perf|revert)(?:\((?<scope>.+)\))?(?<breaking>!)?:\s(?<subject>.{3,})$)(?:(?:(?<BLANK_LINE>\n^$\n)(?<body>(?:^.{3,}$\n?)+))?(?<BLANK_LINE2>\n^$\n)(?:(?<breaking_change>^BREAKING\sCHANGE:\s[\s\w]+$)\n)?(?:(?<footer>^\w+:\s.+)))?\n?|)\Z"
test_str = ("feat(regular-expression_conventionalCommitsỦniçode)!: Subject-3302 úniçode samlpe/\n\n"
"Validating everything for best conventionalCommits usage\n"
"thanks\n"
"Éverything is Ủniçode now\n"
"www.example.com\n\n"
"BREAKING CHANGE: breaking change description\n"
"See: footer.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.