use strict;
my $str = 'feat(regular-expression_conventionalCommitsỦniçode)!: Subject-3302 úniçode samlpe/
Validating everything for best conventionalCommits usage
thanks
Éverything is Ủniçode now
www.example.com
BREAKING CHANGE: breaking change description
See: footer.com';
my $regex = qr/\A(?:(?:^(?<type>feat|fix|ci|chore|docs|test|style|refactor|build|perf|revert)(?:\((?<scope>.+)\))?(?<breaking>!)?:\s(?<subject>.{3,})$)(?:(?:(?<BLANK_LINE>\n^$\n)(?<body>(?:^.{3,}$\n?)+))?(?<BLANK_LINE2>\n^$\n)(?:(?<breaking_change>^BREAKING\sCHANGE:\s[\s\w]+$)\n)?(?:(?<footer>^\w+:\s.+)))?\n?|)\Z/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}