const regex = /\A(?:(?:^(?<type>feat|fix|ci|chore|docs|test|style|refactor|build|perf|revert)(?:\((?<scope>.+)\))?(?<breaking>!)?:\s(?<subject>.{3,})$)(?:(?:(?<BLANK_LINE>\n^$\n)(?<body>(?:^.{3,}$\n?)+))?(?<BLANK_LINE2>\n^$\n)(?:(?<breaking_change>^BREAKING\sCHANGE:\s[\s\w]+$)\n)?(?:(?<footer>^\w+:\s.+)))?\n?|)\Z/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A(?:(?:^(?<type>feat|fix|ci|chore|docs|test|style|refactor|build|perf|revert)(?:\\((?<scope>.+)\\))?(?<breaking>!)?:\\s(?<subject>.{3,})$)(?:(?:(?<BLANK_LINE>\\n^$\\n)(?<body>(?:^.{3,}$\\n?)+))?(?<BLANK_LINE2>\\n^$\\n)(?:(?<breaking_change>^BREAKING\\sCHANGE:\\s[\\s\\w]+$)\\n)?(?:(?<footer>^\\w+:\\s.+)))?\\n?|)\\Z', 'gm')
const str = `feat(regular-expression_conventionalCommitsỦniçode)!: Subject-3302 úniçode samlpe/
Validating everything for best conventionalCommits usage
thanks
Éverything is Ủniçode now
www.example.com
BREAKING CHANGE: breaking change description
See: footer.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}