import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A(?:(?:^(?<type>feat|fix|ci|chore|docs|test|style|refactor|build|perf|revert)(?:\\((?<scope>.+)\\))?(?<breaking>!)?:\\s(?<subject>.{3,})$)(?:(?:(?<BLANK_LINE>\\n^$\\n)(?<body>(?:^.{3,}$\\n?)+))?(?<BLANK_LINE2>\\n^$\\n)(?:(?<breaking_change>^BREAKING\\sCHANGE:\\s[\\s\\w]+$)\\n)?(?:(?<footer>^\\w+:\\s.+)))?\\n?|)\\Z";
final String string = "feat(regular-expression_conventionalCommitsỦniçode)!: Subject-3302 úniçode samlpe/\n\n"
+ "Validating everything for best conventionalCommits usage\n"
+ "thanks\n"
+ "Éverything is Ủniçode now\n"
+ "www.example.com\n\n"
+ "BREAKING CHANGE: breaking change description\n"
+ "See: footer.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}