# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*(?P<IP>(\d{1,3}\.?){4})\s+(?P<MAC>\S+)\s+(?P<TYPE>\w+)"
test_str = ("Интерфейс: 192.168.0.4 --- 0x8\n"
" адрес в Интернете Физический адрес Тип\n"
" 192.168.0.1 34-e0-cf-64-9e-68 динамический\n"
" 192.168.0.7 38-d5-47-17-5f-23 динамический\n"
" 192.168.0.255 ff-ff-ff-ff-ff-ff статический\n"
" 224.0.0.22 01-00-5e-00-00-16 статический\n"
" 224.0.0.251 01-00-5e-00-00-fb статический\n"
" 224.0.0.252 01-00-5e-00-00-fc статический\n"
" 239.255.255.250 01-00-5e-7f-ff-fa статический\n"
" 255.255.255.255 ff-ff-ff-ff-ff-ff статический")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.