#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*(?P<IP>(\d{1,3}\.?){4})\s+(?P<MAC>\S+)\s+(?P<TYPE>\w+)"
Local $sString = "Интерфейс: 192.168.0.4 --- 0x8" & @CRLF & _
" адрес в Интернете Физический адрес Тип" & @CRLF & _
" 192.168.0.1 34-e0-cf-64-9e-68 динамический" & @CRLF & _
" 192.168.0.7 38-d5-47-17-5f-23 динамический" & @CRLF & _
" 192.168.0.255 ff-ff-ff-ff-ff-ff статический" & @CRLF & _
" 224.0.0.22 01-00-5e-00-00-16 статический" & @CRLF & _
" 224.0.0.251 01-00-5e-00-00-fb статический" & @CRLF & _
" 224.0.0.252 01-00-5e-00-00-fc статический" & @CRLF & _
" 239.255.255.250 01-00-5e-7f-ff-fa статический" & @CRLF & _
" 255.255.255.255 ff-ff-ff-ff-ff-ff статический"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")