package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(?P<IP>(\d{1,3}\.?){4})\s+(?P<MAC>\S+)\s+(?P<TYPE>\w+)`)
var str = `Интерфейс: 192.168.0.4 --- 0x8
адрес в Интернете Физический адрес Тип
192.168.0.1 34-e0-cf-64-9e-68 динамический
192.168.0.7 38-d5-47-17-5f-23 динамический
192.168.0.255 ff-ff-ff-ff-ff-ff статический
224.0.0.22 01-00-5e-00-00-16 статический
224.0.0.251 01-00-5e-00-00-fb статический
224.0.0.252 01-00-5e-00-00-fc статический
239.255.255.250 01-00-5e-7f-ff-fa статический
255.255.255.255 ff-ff-ff-ff-ff-ff статический`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}