import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(?P<IP>(\\d{1,3}\\.?){4})\\s+(?P<MAC>\\S+)\\s+(?P<TYPE>\\w+)";
final String string = "Интерфейс: 192.168.0.4 --- 0x8\n"
+ " адрес в Интернете Физический адрес Тип\n"
+ " 192.168.0.1 34-e0-cf-64-9e-68 динамический\n"
+ " 192.168.0.7 38-d5-47-17-5f-23 динамический\n"
+ " 192.168.0.255 ff-ff-ff-ff-ff-ff статический\n"
+ " 224.0.0.22 01-00-5e-00-00-16 статический\n"
+ " 224.0.0.251 01-00-5e-00-00-fb статический\n"
+ " 224.0.0.252 01-00-5e-00-00-fc статический\n"
+ " 239.255.255.250 01-00-5e-7f-ff-fa статический\n"
+ " 255.255.255.255 ff-ff-ff-ff-ff-ff статический";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}