// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)gene_id \\"([^;]*)\\";"#).unwrap();
let string = "gene_id \\\"Centrin-2_1\\\"; transcript_id \\\"\\\"; db_xref \\\"GeneID:100757715\\\"; gbkey \\\"Gene\\\"; gene \\\"Centrin-2\\\"; gene_biotype \\\"protein_coding\\\";";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}