#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)gene_id \\"([^;]*)\\";"
Local $sString = "gene_id \"Centrin-2_1\"; transcript_id \"\"; db_xref \"GeneID:100757715\"; gbkey \"Gene\"; gene \"Centrin-2\"; gene_biotype \"protein_coding\";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")