import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "gene_id \\\\\"([^;]*)\\\\\";";
final String string = "gene_id \\\"Centrin-2_1\\\"; transcript_id \\\"\\\"; db_xref \\\"GeneID:100757715\\\"; gbkey \\\"Gene\\\"; gene \\\"Centrin-2\\\"; gene_biotype \\\"protein_coding\\\";";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}