re = /gene_id \\"([^;]*)\\";/m
str = 'gene_id \\"Centrin-2_1\\"; transcript_id \\"\\"; db_xref \\"GeneID:100757715\\"; gbkey \\"Gene\\"; gene \\"Centrin-2\\"; gene_biotype \\"protein_coding\\";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end