$re = '/gene_id \\\\"([^;]*)\\\\";/m';
$str = 'gene_id \\"Centrin-2_1\\"; transcript_id \\"\\"; db_xref \\"GeneID:100757715\\"; gbkey \\"Gene\\"; gene \\"Centrin-2\\"; gene_biotype \\"protein_coding\\";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);