re = /(\d{3})(-|.) ?(\d{3})[.-](\d{3,4})/m
str = 'Frank . 938-345-678
Thomas (345) 654.5654
TC 435.566.333
Rick 245-345.3453'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end