#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{3})(-|.) ?(\d{3})[.-](\d{3,4})"
Local $sString = "Frank . 938-345-678" & @CRLF & _
"Thomas (345) 654.5654" & @CRLF & _
"TC 435.566.333" & @CRLF & _
"Rick 245-345.3453"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")