import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{3})(-|.) ?(\\d{3})[.-](\\d{3,4})";
final String string = "Frank . 938-345-678\n"
+ "Thomas (345) 654.5654\n"
+ "TC 435.566.333\n"
+ "Rick 245-345.3453";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}