using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{3})(-|.) ?(\d{3})[.-](\d{3,4})";
string input = @"Frank . 938-345-678
Thomas (345) 654.5654
TC 435.566.333
Rick 245-345.3453";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}