use strict;
my $str = 'Frank . 938-345-678
Thomas (345) 654.5654
TC 435.566.333
Rick 245-345.3453';
my $regex = qr/(\d{3})(-|.) ?(\d{3})[.-](\d{3,4})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}